Titan's not dying.

╮(╯_╰)╭ ok...I know there're tons of bugs....( ̄▽ ̄)~*
- Made by Feng, title edited by Accelevi

Titan's not dying.

Postby Connorhere » Sun May 18, 2014 3:42 pm

This has sort of always been apparent and its basically always due to server lagg or connection problems but as of the new update i've seen it happen more often when there have been absolutely no server complications at all.

Basically occasionally when i go to slash a titan's nape it just doesn't record the hit and keeps on moving, and everyone is still moving including the titans, who are happy to keep on attacking so its not lagg/connection. The special animation and sound effect happen but no death, it's also happened 3 times in a row, each slash not working after hopping on and off the titan until my final one killed it. Usually its the connection but its happening more commonly now for me.

Does this happen to anyone else?
Connorhere
 

 

Re: Titan's not dying.

Postby turtletots » Sun May 18, 2014 6:04 pm

Happened to me but when i play, some titans you can kill, once i kill all the titans that i can kill the non-killable titans are now killable.
turtletots
 

Re: Titan's not dying.

Postby Connorhere » Sun May 18, 2014 9:21 pm

They're never invincible for me, its just occasionally the kill won't actually kill them, after another try or two they end up dying.
Connorhere
 

Re: Titan's not dying.

Postby Connorhere » Tue May 20, 2014 7:07 pm

I've noticed this happening more and more recently after the newest update, happening 4 times in one game. All in roughly under 10 minutes.
Connorhere
 

Re: Titan's not dying.

Postby Terminus » Wed May 21, 2014 3:33 am

Yeah occasionally I'll hack and slash like 7 times on the nape and never get anywhere. It's a bit annoying since I'd normally have high damage kills rater than a measly 10. Also, in a related tangent, I slashed a nape, it didn't register at first, allowing the titan to get off a swing before dying, killing a teammate.
Terminus
 

Re: Titan's not dying.

Postby Connorhere » Wed May 21, 2014 9:25 am

Thats happened with me before. Commonly for me the false-slashes happen if the titan is moving quickly, or activates some sort of attack animation or something. I blatantly killed a titan as they jumped and another time when they body slammed both mid-animation and they were uneffected.
Connorhere
 

Re: Titan's not dying.

Postby pokemon123 » Fri May 23, 2014 11:12 am

It also happened to me.when either i'm moving too fast and get the slash (for example during vector slash) the damage wasn't registered even when the blue slash thing appears and when the Titan is moving so fast with no pause (for example : player titans ) It's incredibly annoying.
pokemon123
 

Re: Titan's not dying.

Postby Connorhere » Mon May 26, 2014 12:52 am

Yeah, i don't think it's due to lag either. Most of the time the server is running perfectly and i've seen it happen to other players be it when i'm beside them or viewing through them after death.
Connorhere
 

Re: Titan's not dying.

Postby SlyThePug » Tue Jul 01, 2014 11:05 pm

This bug is terrible, I'll kill a titan with a good 750 and then it smacks me off its nape then it falls down!
SlyThePug
 

Re: Titan's not dying.

Postby TheEpicWolf500 » Tue Jul 15, 2014 3:06 pm

This bug happens to me too. My ping is around 30-80 and I slice the nape. I see it, I hear it, and yet it's still alive. This happened to me once when I was fighting a PT on the wall and I sliced it's nape a few times and it was still alive...
TheEpicWolf500
 


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest